Had my main controller stolen, bought 2 more and can’t connect either of them? Please help

Discussion in 'New User Center' started by Emily10, Mar 14, 2021.

  1. Emily10

    Emily10 PSLS Level: Newbie

    Joined:
    Mar 14, 2021
    Messages:
    1
    Likes Received:
    0
    My dominant controller was stolen, so I had to replace it. For some reason neither will connect, they are both fully charged but I can not get past this screen. I have tried one of them on my sisters ps4 and it connected no problem (I made sure to forget device on there, before trying on mine again)

    I’ve tried different usb cables, tried resetting them both with the little button in the back, but nothing?
    Thanks in advance
    Em
     

    Attached Files:

  2. avensis

    avensis PSLS Level: Bronze

    Joined:
    Mar 3, 2019
    Messages:
    17
    Likes Received:
    0
    Last edited: May 18, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice